
STATEMENT OF TRANSACTION REPORT ANALYSIS 

USING EXCEL 
Excel can be used to analyze the MCPS Statement of Transaction EXCEL Report – Selected 

Fields to more easily track expenses through the procurement cycle.  Excel enables you to 

customize the data displayed in the initial report to meet your needs.     

Cut, Paste and Arrange Column Headers  

When the report is first generated, the information is displayed in a pre-determined order of 

column headers that may or may not be useful for your analysis.  Using Excel you can cut, paste 

and arrange the order of these column headers in such a way that is more meaningful for you. 

 To cut, paste and arrange columns in Excel 2003 and 2007 

1. Right-click the column header desired to be moved and click Cut from the drop-down menu. 

2. Hover the mouse over the column to the left of the new location where the cut column header 

is desired to be placed.  Right-click in that location and click Insert Cut Cells. 

Deleting and Hiding Column Headers 

Using Excel you have the ability to delete and/or hide specific column headers you may not need.  

If you are unsure about the necessity or usefulness of a given column header it is best to hide it 

from the spreadsheet view.  A column header can easily be re-displayed by selecting the unhide 

option.  If you are certain about not needing a given column header you can opt to delete it.  

However, if you choose this option it can only be redone by selecting the undo button repeatedly.  

 To delete a column header in Excel 2003 and 2007 

1. Right-click the column header you wish to remove and select Delete from the drop-down 

menu. 

 To hide a column header in Excel 2003 and 2007 

1.  Right-click the column header you wish to hide and select Hide from the drop-down menu. 

2. To unhide a hidden column header, highlight the column headers to the right and left of 

where the hidden column originally appeared.  Right-click and click Unhide from the drop-

down menu. 

Applying an AutoFilter 

The AutoFilter feature of Excel enables you to select just the data you need to see and hides all 

the rest.  For example, if there are ten purchase orders for a given account, the AutoFilter feature 

allows you to select an isolated purchase order or grouping of purchase orders to view.  Selecting 

a specific purchase order with AutoFilter shows other information related to the specific purchase 

order such as total expense and receipt number.  Using the AutoFilter features doesn’t change 
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your data in anyway.  As soon as you remove the filter all your data reappears exactly as it was 

before.   

 To apply an AutoFilter in Excel 2007 

1. Click the Data tab. 

2. Click the Filter button in the Sort & Filter grouping on the Data tab ribbon.  This applies an 

AutoFilter to every column header in the first row.  If you wish to apply an AutoFilter to only 

certain column headers, highlight those specific columns first and then follow steps 1 and 2. 

 To apply an AutoFilter in Excel 2003 

1. Click the Data toolbar.  Hover over Filter in the drop-down menu and click AutoFilter from 

the pop out menu on the right. 

NOTE:  If you wish to apply an AutoFilter to non-consecutive columns hold the Ctrl key 

while selecting each column header.  This applies to both Excel 2003 and 2007. 

Freezing Panes 

Freezing panes allows you to select specific rows or columns that remain visible when scrolling 

in the worksheet.  For example, you freeze panes to keep column headers visible as you scroll 

through the spreadsheet to view data that is displayed in rows that may exceed the viewing area 

of the monitor.   

 To freeze a pane in Excel 2007 

1. Click the View tab. 

2. Click the Freeze Panes button in the Window grouping on the View tab ribbon.   

3. Click the Freeze Top Row option from the drop-down menu.  

4. To unfreeze a pane repeat steps 1 and 2 and select UnFreeze Panes from the drop-down 

menu. 

 To freeze a pane in Excel 2003 

1. To freeze the first row containing column headers, click on the number 2 cell to highlight the 

entire row. 

 

Freeze pane in Excel 2003 example 

2. Click the Window toolbar and select Freeze Panes from the drop-down menu.  It is always 

the row above the row that you are applying a Freeze Pane to that actually freezes in place. 
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Creating a Pivot Table 

Pivot tables allow you organize, summarize, compile and analyze large amounts of data to see 

trends and patterns in a quick glance.  

 To create a pivot table in Excel 2007 

1. Click the Insert tab. 

2. Click the PivotTable button in the Tables grouping on the Insert tab ribbon. 

3. From Create PivotTable dialog box check to make sure the radio button option of Select a 

table or range is selected.  Notice the range for your entire spreadsheet is specified in the 

field below. 

 

Create PivotTable dialog box 

4. Click OK.  

5. In the PivotTable Field List, located on the far right side, check inside the check box for 

ACCOUNT_SEG. 

6. Look to see where the ACCOUNT_SEG field has been placed in the four quadrants shown 

below the PivotTable Field List.  If not already there, drag the ACCOUNT_SEG field drag to 

the Report Filter quadrant.  
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PivotTable Field List dialog box 

7. Right-click on the ACCOUNT_SEG field where it appears in the spreadsheet and click 

PivotTable Options from the drop-down menu. 

 

PivotTable options menu 
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8. Click the Display tab and check the checkbox for Classic PivotTable layout. 

 

PivotTable Options dialog box 

9. Click the OK button. 

10. The end result will look like the screenshot below.  As more fields are selected to be part of 

the PivotTable the PivotTable’s appearance will change. 

 

PivotTable template 

11. Place checks inside the checkboxes for the following fields displayed in the PivotTable Field 

List in the order presented below.  Notice each field being placed in the Row Labels quadrant 

after being checked. 
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 PURCHASE_ORDER 

 REQUISITION_NUMBER 

 RELEASE_NUM 

 RECEIPT_NUM 

 CHECK_NUMBER 

 

Report filters 

12. Right-click each column header identified in step 11 and click SUBTOTAL “Field Name” 

from the drop-down menu.  Notice that as a result of this step the data in each column is not 

being subtotaled.   

 

Field options 

13. Place checks inside the checkboxes for the following fields displayed in the PivotTable Field 

List in the order presented below.  Notice each field being placed in the Row Labels quadrant 

after being checked.  
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 ENC_COMMITMENT 

 ENC_OBLIGATION 

 ENC_OTHER 

 ACTUAL 

14. Drag and drop the fields identified in step 13 from the Row Labels quadrant to the Values 

quadrant.   

 

PivotTable Field List dialog box 

15. Right-click the column headers identified step 13.  Hover over Summarize Data By and 

click Sum in the pop-out menu.  Repeat this step for each column header identified in step 

13. 
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Summarize data options 

16. Click the lettered column header above the ENC_COMMITMENT field.  Notice this will 

select the entire column.  Hold the Shift key and click the lettered column header above the 

Actual column.  Notice the columns from ENC_COMMITMENT to ACTUAL are 

highlighted.   

17. Right click one highlighted cell and click Format Cells from the pop-up menu. 

18. Click the Number tab and select Number from the list on the left.  Next, set the number of 

decimal places to 2 by using the arrows to the right of the Decimal Places field.   
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Format Cells options 

19. Click the OK button.  Notice the commitment, obligation, other and actual columns are now 

formatted as numbers with 2 decimal places. 

20. Left-click, hold and highlight the entire pivot table.  Next, right-click on one of the 

highlighted cells and click Format Cells from the pop-up menu. 

21. Click the Border tab and click the Outline and Inside buttons. 
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Format Cells options 

22. Click the OK button.  Notice the pivot table has visible grid lines. 

23. Now the pivot table is complete and can be used to interpret and analyze purchase orders’ 

movement through the entire procurement cycle; requisition to purchase order to 

encumbrances to actual to receipt number and finally to a check number. 

 To create a pivot table in Excel 2003 

1. Click the Data toolbar and click PivotTable and PivotChart Report from the drop-down 

menu. 

On the PivotTable and PivotChart Wizard—Step 1 of 3, check to make sure that the radio buttons 

for Microsoft Office Excel list or database and  PivotTable are selected.  Then click Next.  

 

PivotTable and PivotChart Wizard 
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2. Notice the range for your entire spreadsheet is specified in the Range field.  Click the Next 

button. 

 

PivotTable and PivotChart Wizard 

3. On the PivotTable and PivotChart Wizard – Step 3 of 3 make sure the New worksheet radio 

button is selected.  Click the Finish button.  Notice this creates the shell of a pivot table on 

the spreadsheet. 

 

PivotTable and PivotChart Wizard 

4. From the PivotTable Field List dialog box click, hold and drag the ACCOUNT_SEG field to 

the Drop Page Fields Here area of the pivot table. 

 

PivotTable template 
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5. Drag and drop the following fields displayed in the PivotTable Field List dialog box to the 

Drop Row Fields Here area of the pivot table.  The fields should be presented left to right in 

the order specified below.   

a. PURCHASE_ORDER 

b. REQUISITION_NUMBER 

c. RELEASE_NUM 

d. RECEIPT_NUM 

e. CHECK_NUMBER 

 

PivotTable template 

6. Right-click each column header identified in step 6 and click Field Settings from the drop-

down menu.  From the PivotTable Field dialog box, click the radio button for None under the 

Subtotals option.  After each field is set not to calculate a subtotal click the OK button.  

Notice as a result of this step the data in each column is not being subtotaled.   

 

PivotTable Field dialog box 

7. Drag and drop the following fields displayed below from the PivotTable Field List dialog box 

to the Drop Data Items Here area of the pivot table. 
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a. ENC_COMMITMENT 

b. ENC_OBLIGATION 

c. ENC_OTHER 

d. ACTUAL 

 

PivotTable template 

8. Notice under the Data column header the pivot table is counting each commitment, 

obligation, other and actual.  To correct this, right-click on the first set of data fields listed 

below that are associated with the first purchase order shown on the far left side of the pivot 

table.  Click Field Settings from the dialog box. 

a. COUNT OF ENC_COMMITMENT 

b. COUNT OF ENC_OBLIGATION 

c. COUNT OF ENC_OTHER 

d. COUNT OF ACTUAL 

9. In the Summarize by list of items, choose Sum and click the OK button. 

  
PivotTable Field dialog box  

10. You will need to repeat steps 9 and 10 for all of the fields identified in step 8.  Notice that the 

pivot table is now summing the data instead of counting the data. 
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11. Click the lettered column header above the Total field.  Notice this will select the entire 

column.  

12. Right-click one highlighted cell and click Format Cells from the drop-down menu. 

13. Click the Number tab and select Number from the list on the left.  Next, set the number of 

decimal places to 2 by using the arrows to the right of the Decimal Places field.   

 

Format Cells dialog box 

14. Click the OK button.  Notice the commitment, obligation, other and actual columns are now 

formatted as numbers with 2 decimal places. 

15. Now the pivot table is complete and can be used to interpret and analyze purchase orders’ 

movement through the entire procurement cycle; requisition to purchase order to 

encumbrances to actual to receipt number and finally to a check number. 

 

 

 

 


